En bref
- CVE-2021-40110 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.apache.james:james-server, james (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.0%, plus élevée que 87.2% des vulnérabilités.
- Correctif : mettre à jour vers 3.6.1 ou plus récent.
Description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
NVD description
In Apache James, using Jazzer fuzzer, we identified that an IMAP user can craft IMAP LIST commands to orchestrate a Denial Of Service using a vulnerable Regular expression. This affected Apache James prior to 3.6.1 We recommend upgrading to Apache James 3.6.1 or higher , which enforce the use of RE2J regular expression engine to execute regex in linear time without back-tracking.
Autres vulnérabilités de org.apache.james:james-server
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free