En bref
- CVE-2021-40865 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant org.apache.storm:storm, storm (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 64.2%, plus élevée que 99.2% des vulnérabilités.
- Correctif : mettre à jour vers 1.2.4, 2.1.1, 2.2.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.storm:storm Maven | ≥ 1.0.0, < 1.2.4≥ 2.1.0, < 2.1.1≥ 2.2.0, < 2.2.1
| 1.2.42.1.12.2.1
|
| storm | ≥ 1.0.0, < 1.2.4≥ 2.1.0, < 2.1.1≥ 2.2.0, < 2.2.1
| 1.2.42.1.12.2.1
|
Description
An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4
NVD description
An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4
Autres vulnérabilités de org.apache.storm:storm
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free