En bref
- CVE-2021-41104 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant esphome.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.2%, plus élevée que 68.7% des vulnérabilités.
- Correctif : mettre à jour vers 2021.9.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| esphome PyPI | < 2021.9.2
| 2021.9.2
|
Description
Impact
Anyone with web_server enabled and HTTP basic auth configured on 2021.9.1 or older
web_server allows OTA update without checking user defined basic auth username & password
Patches
Patch released in 2021.9.2
Workarounds
Disable/remove web_server
NVD description
ESPHome is a system to control the ESP8266/ESP32. Anyone with web_server enabled and HTTP basic auth configured on version 2021.9.1 or older is vulnerable to an issue in which `web_server` allows over-the-air (OTA) updates without checking user defined basic auth username & password. This issue is patched in version 2021.9.2. As a workaround, one may disable or remove `web_server`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free