En bref
- CVE-2021-41116 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant composer/composer, composer (getcomposer), tenable.sc (tenable).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.8%, plus élevée que 86.6% des vulnérabilités.
- Correctif : mettre à jour vers 2.1.9, 1.10.23, 5.21.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| composer/composer Packagist | ≥ 2.0.0-alpha1, < 2.1.9< 1.10.23
| 2.1.91.10.23
|
| composer | ≥ 2.0.0, < 2.1.9< 1.10.23
| 2.1.91.10.23
|
| tenable.sc | < 5.21.0
| 5.21.0
|
Description
Impact
Windows users running Composer to install untrusted dependencies are affected and should definitely upgrade for safety. Other OSs and WSL are not affected.
Patches
1.10.23 and 2.1.9 fix the issue
Workarounds
None
NVD description
Composer is an open source dependency manager for the PHP language. In affected versions windows users running Composer to install untrusted dependencies are subject to command injection and should upgrade their composer version. Other OSs and WSL are not affected. The issue has been resolved in composer versions 1.10.23 and 2.1.9. There are no workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free