En bref
- CVE-2021-41269 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant com.cronutils:cron-utils, cron-utils (cron-utils project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 4.3%, plus élevée que 91.3% des vulnérabilités.
- Correctif : mettre à jour vers 9.1.6 ou plus récent.
Description
Impact
A Template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected.
Patches
The issue was patched and a new version was released. Please upgrade to version 9.1.6.
Workarounds
There are no known workarounds up to this moment.
References
A description of the issue is provided in issue 461
For more information
If you have any questions or comments about this advisory:
Open an issue in the cron-utils Github repository
NVD description
cron-utils is a Java library to define, parse, validate, migrate crons as well as get human readable descriptions for them. In affected versions A template Injection was identified in cron-utils enabling attackers to inject arbitrary Java EL expressions, leading to unauthenticated Remote Code Execution (RCE) vulnerability. Versions up to 9.1.2 are susceptible to this vulnerability. Please note, that only projects using the @Cron annotation to validate untrusted Cron expressions are affected. The issue was patched and a new version was released. Please upgrade to version 9.1.6. There are no known workarounds known.
Autres vulnérabilités de com.cronutils:cron-utils
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free