En bref
- CVE-2021-43840 est une vulnérabilité MOYENNE (CVSS 6.5) touchant message_bus, message bus (discourse).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.9%, plus élevée que 80.2% des vulnérabilités.
- Correctif : mettre à jour vers 3.3.7 ou plus récent.
Description
Impact
Users who deployed message bus with diagnostics features enabled (default off) were vulnerable to a path traversal bug, which could lead to disclosure of secret information on a machine if an unintended user were to gain access to the diagnostic route. The impact is also greater if there is no proxy for your web application as the number of steps up the directories is not bounded. For deployments which uses a proxy, the impact varies. For example, If a request goes through a proxy like Nginx with merge_slashes enabled, the number of steps up the directories that can be read is limited to 3 levels.
Patches
Patched in 3.3.7.
Workarounds
Disable MessageBus::Diagnostics in production like environments.
NVD description
message_bus is a messaging bus for Ruby processes and web clients. In versions prior to 3.3.7 users who deployed message bus with diagnostics features enabled (default off) are vulnerable to a path traversal bug, which could lead to disclosure of secret information on a machine if an unintended user were to gain access to the diagnostic route. The impact is also greater if there is no proxy for your web application as the number of steps up the directories is not bounded. For deployments which uses a proxy, the impact varies. For example, If a request goes through a proxy like Nginx with `merge_slashes` enabled, the number of steps up the directories that can be read is limited to 3 levels. This issue has been patched in version 3.3.7. Users unable to upgrade should ensure that MessageBus::Diagnostics is disabled.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free