En bref
- CVE-2022-21647 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant codeigniter4/framework, codeigniter (codeigniter).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 37.7%, plus élevée que 98.5% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.6 ou plus récent.
Description
Impact
Deserialization of Untrusted Data was found in the old() function in CodeIgniter4.
Remote attackers may inject auto-loadable arbitrary objects with this vulnerability,
and possibly execute existing PHP code on the server.
We are aware of a working exploit, which can lead to SQL injection.
Patches
Upgrade to v4.1.6 or later.
Workarounds
Do not use:
old() and form_helper
RedirectResponse::withInput() and redirect()->withInput()
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is an open source PHP full-stack web framework. Deserialization of Untrusted Data was found in the `old()` function in CodeIgniter4. Remote attackers may inject auto-loadable arbitrary objects with this vulnerability, and possibly execute existing PHP code on the server. We are aware of a working exploit, which can lead to SQL injection. Users are advised to upgrade to v4.1.6 or later. Users unable to upgrade as advised to not use the `old()` function and form_helper nor `RedirectResponse::withInput()` and `redirect()->withInput()`.
Autres vulnérabilités de codeigniter4/framework
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free