En bref
- CVE-2022-23472 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant passeo, passeo (passeo project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.86%, plus élevée que 58.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.0.5 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| passeo PyPI | < 1.0.5
| 1.0.5
|
| passeo | < 1.0.5
| 1.0.5
|
Description
Impact
Everyone below v1.0.5 is impacted by this flaw, of confidentiality being at risk due to the password(s) being easily able to be guessed with Passeo's use of the random library. It is recommended to change any passwords made with Passeo before v1.0.5 and upgrade to v1.0.5, and v1.0.5 patches this with the secrets library.
Workarounds
No current workaround available than updating to v1.0.5.
NVD description
Passeo is an open source python password generator. Versions prior to 1.0.5 rely on the python `random` library for random value selection. The python `random` library warns that it should not be used for security purposes due to its reliance on a non-cryptographically secure random number generator. As a result a motivated attacker may be able to guess generated passwords. This issue has been addressed in version 1.0.5. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free