En bref
- CVE-2022-23517 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant rails-html-sanitizer, rails html sanitizers (rubyonrails).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.6%, plus élevée que 75.5% des vulnérabilités.
- Correctif : mettre à jour vers 1.4.4 ou plus récent.
Description
Summary
Certain configurations of rails-html-sanitizer < 1.4.4 use an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption.
Mitigation
Upgrade to rails-html-sanitizer >= 1.4.4.
Severity
The maintainers have evaluated this as High Severity 7.5 (CVSS3.1).
References
Credit
This vulnerability was responsibly reported by @ooooooo-q (https://github.com/ooooooo-q).
NVD description
rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Certain configurations of rails-html-sanitizer < 1.4.4 use an inefficient regular expression that is susceptible to excessive backtracking when attempting to sanitize certain SVG attributes. This may lead to a denial of service through CPU resource consumption. This issue has been patched in version 1.4.4.
Autres vulnérabilités de rails-html-sanitizer
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free