En bref
- CVE-2022-23556 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant codeigniter4/framework, codeigniter (codeigniter).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.40%, plus élevée que 34.0% des vulnérabilités.
- Correctif : mettre à jour vers 4.2.11 ou plus récent.
Description
Impact
This vulnerability may allow attackers to spoof their IP address when your server is behind a reverse proxy.
Patches
Upgrade to v4.2.11 or later, and configure Config\App::$proxyIPs.
Workarounds
Do not use $request->getIPAddress().
References
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.
Autres vulnérabilités de codeigniter4/framework
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free