En bref
- CVE-2022-23647 est une vulnérabilité MOYENNE (CVSS 6.1) touchant prism (prismjs), prismjs.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.4%, plus élevée que 72.9% des vulnérabilités.
- Correctif : mettre à jour vers 1.27.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| prism | ≥ 1.14.0, < 1.27.0
| 1.27.0
|
| prismjs npm | ≥ 1.14.0, < 1.27.0
| 1.27.0
|
Description
Impact
Prism's Command line plugin can be used by attackers to achieve an XSS attack. The Command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code.
Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted.
Patches
This bug has been fixed in v1.27.0.
Workarounds
Do not use the Command line plugin on untrusted inputs, or sanitized all code blocks (remove all HTML code text) from all code blocks that use the Command line plugin.
References
NVD description
Prism is a syntax highlighting library. Starting with version 1.14.0 and prior to version 1.27.0, Prism's command line plugin can be used by attackers to achieve a cross-site scripting attack. The command line plugin did not properly escape its output, leading to the input text being inserted into the DOM as HTML code. Server-side usage of Prism is not impacted. Websites that do not use the Command Line plugin are also not impacted. This bug has been fixed in v1.27.0. As a workaround, do not use the command line plugin on untrusted inputs, or sanitize all code blocks (remove all HTML code text) from all code blocks that use the command line plugin.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free