En bref
- CVE-2022-24685 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant github.com/hashicorp/nomad, nomad (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.5%, plus élevée que 75.0% des vulnérabilités.
- Correctif : mettre à jour vers 1.0.17, 1.1.12, 1.2.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/nomad Go | ≥ 1.0.0, < 1.0.17≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6
| 1.0.171.1.121.2.6
|
| nomad | ≥ 1.0.0, ≤ 1.0.17≥ 1.1.0, < 1.1.12≥ 1.2.0, < 1.2.6
| 1.1.121.2.6
|
Description
HashiCorp Nomad and Nomad Enterprise 1.x before 1.0.17, 1.1.x before 1.1.12, and 1.2.x before 1.2.6 is vulnerable to Allocation of Resources Without Limits or Throttling.
NVD description
HashiCorp Nomad and Nomad Enterprise 1.0.17, 1.1.11, and 1.2.5 allow invalid HCL for the jobs parse endpoint, which may cause excessive CPU usage. Fixed in 1.0.18, 1.1.12, and 1.2.6.
Autres vulnérabilités de github.com/hashicorp/nomad
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free