En bref
- CVE-2022-24709 est une vulnérabilité MOYENNE (CVSS 6.1) touchant awsui/components-react (amazon), @awsui/components-react.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.69%, plus élevée que 52.9% des vulnérabilités.
- Correctif : mettre à jour vers 3.0.367 ou plus récent.
Description
Impact
Components could potentially allow cross-site scripting (XSS) in certain circumstances. These components could render content without adequate neutralization.
Patches
Fixed in 3.0.367.
NVD description
@awsui/components-react is the main AWS UI package which contains React components, with TypeScript definitions designed for user interface development. Multiple components in versions before 3.0.367 have been found to not properly neutralize user input and may allow for javascript injection. Users are advised to upgrade to version 3.0.367 or later. There are no known workarounds for this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free