En bref
- CVE-2022-24721 est une vulnérabilité ÉLEVÉE (CVSS 8.1) touchant org.cometd.java:cometd-java-oort, cometd (cometd).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.1%, plus élevée que 67.0% des vulnérabilités.
- Correctif : mettre à jour vers 6.0.6, 7.0.6, 5.0.11 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.cometd.java:cometd-java-oort Maven | ≥ 6.0.0, < 6.0.6≥ 7.0.0, < 7.0.6< 5.0.11
| 6.0.67.0.65.0.11
|
| cometd | ≥ 6.0.0, < 6.0.6≥ 7.0.0, < 7.0.6< 5.0.11
| 6.0.67.0.65.0.11
|
Description
Impact
Internal usage of Oort and Seti channels is improperly authorized, so any remote user could subscribe and publish to those channels.
By subscribing to those channels, a remote user may be able to watch cluster-internal traffic that contains other user's (possibly sensitive) data.
By publishing to those channels, a remote user may be able to create/modify/delete other user's data and modify the cluster structure.
The issue impacts any version up to 5.0.10, 6.0.5 and 7.0.5.
Patches
The issue has been fixed in 5.0.11, 6.0.6 and 7.0.6.
Workarounds
The workaround is to install a custom SecurityPolicy that forbids subscription and publishing to remote, non-Oort, sessions on Oort and Seti channels.
This workaround could be implemented in any affected version.
References
cometd/cometd#1146
For more information
If you have any questions or comments about this advisory:
Credits
https://www.redteam-pentesting.de/
NVD description
CometD is a scalable comet implementation for web messaging. In any version prior to 5.0.11, 6.0.6, and 7.0.6, internal usage of Oort and Seti channels is improperly authorized, so any remote user could subscribe and publish to those channels. By subscribing to those channels, a remote user may be able to watch cluster-internal traffic that contains other users' (possibly sensitive) data. By publishing to those channels, a remote user may be able to create/modify/delete other user's data and modify the cluster structure. A fix is available in versions 5.0.11, 6.0.6, and 7.0.6. As a workaround, install a custom `SecurityPolicy` that forbids subscription and publishing to remote, non-Oort, sessions on Oort and Seti channels.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free