| Package | Affected versions | Patched versions |
|---|---|---|
| muhammara | = 3.0.0= 3.1.0< 2.6.1 | 2.6.1 |
| hummus | < 1.0.111 | 1.0.111 |
| muhammara | ≥ 3.0.0, < 3.1.1< 2.6.1 | 3.1.12.6.1 |
The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed.
It has been patched in 3.1.1 and has been backported to 2.6.1 Hummus has a patch in 1.0.111.
Do not process files from untrusted sources or update.
https://nvd.nist.gov/vuln/detail/CVE-2022-25892 https://github.com/galkahana/HummusJS/issues/463 https://github.com/julianhille/MuhammaraJS/issues/214 https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002 https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51 https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138 https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free