En bref
- CVE-2022-28730 est une vulnérabilité MOYENNE (CVSS 6.1) touchant org.apache.jspwiki:jspwiki-main, jspwiki (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 86.2%, plus élevée que 99.7% des vulnérabilités.
- Correctif : mettre à jour vers 2.11.3 ou plus récent.
Description
A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.
NVD description
A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.
Autres vulnérabilités de org.apache.jspwiki:jspwiki-main
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free