En bref
- CVE-2022-29221 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant smarty/smarty, smarty (smarty).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 4.9%, plus élevée que 92.1% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.1, 3.1.45 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| smarty/smarty Packagist | ≥ 4.0.0, < 4.1.1< 3.1.45
| 4.1.13.1.45
|
| smarty | ≥ 4.0.0, < 4.1.1< 3.1.45
| 4.1.13.1.45
|
Description
Impact
Template authors could inject php code by choosing a malicous {block} name or {include} file name. Sites that cannot fully trust template authors should update asap.
Patches
Please upgrade to the most recent version of Smarty v3 or v4.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
References
Are there any links users can visit to find out more?
For more information
If you have any questions or comments about this advisory:
NVD description
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to versions 3.1.45 and 4.1.1, template authors could inject php code by choosing a malicious {block} name or {include} file name. Sites that cannot fully trust template authors should upgrade to versions 3.1.45 or 4.1.1 to receive a patch for this issue. There are currently no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free