En bref
- CVE-2022-31037 est une vulnérabilité MOYENNE (CVSS 5.4) touchant oro/commerce, orocommerce (oroinc).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.50%, plus élevée que 43.2% des vulnérabilités.
- Correctif : mettre à jour vers 5.0.6 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| oro/commerce Packagist | ≥ 4.1.0, < 5.0.6
| 5.0.6
|
| orocommerce | ≥ 4.1.0, ≤ 4.1.17≥ 4.2.0, ≤ 4.2.11≥ 5.0.0, ≤ 5.0.3
| No fix yet |
Description
Impact
Shipping rule edit page is vulnerable to cross site scripting (XSS) payload added to UPS Surcharge field. The attacker should have permission to create or edit a shipping rule.
NVD description
OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free