En bref
- CVE-2022-31147 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant jquery validation (jqueryvalidation), jquery-validation.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.2%, plus élevée que 82.9% des vulnérabilités.
- Correctif : mettre à jour vers 1.19.5 ou plus récent.
Description
Summary
Incomplete fix of CVE-2021-43306: An exponential ReDoS (Regular Expression Denial of Service) can be triggered in the jquery-validation npm package, when an attacker is able to supply arbitrary input to the url2 method.
NVD description
The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free