En bref
- CVE-2022-31158 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant packbackbooks/lti-1-3-php-library, lti 1.3 tool library (packback).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.86%, plus élevée que 58.6% des vulnérabilités.
- Correctif : mettre à jour vers 5.0, 5.0.0 ou plus récent.
Description
Impact
Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request.
Patches
Users should upgrade to version 5.0 immediately
Workarounds
None.
NVD description
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
Autres vulnérabilités de packbackbooks/lti-1-3-php-library
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free