En bref
- CVE-2022-36024 est une vulnérabilité MOYENNE (CVSS 6.5) touchant py-cord, pycord (pycord development).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.82%, plus élevée que 57.5% des vulnérabilités.
- Correctif : mettre à jour vers 2.0.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| py-cord PyPI | ≥ 2.0.0, < 2.0.1
| 2.0.1
|
| pycord | = 2.0.0
| No fix yet |
Description
Impact
py-cord is a an API wrapper for Discord written in Python. Bots using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the application.commands scope without the bot scope. Currently, it appears that all public bots that use slash commands are affected.
Patches
This issue has been patched in version 2.0.1.
Workarounds
There are currently no recommended workarounds - please upgrade to a patched version.
References
https://github.com/Pycord-Development/pycord/pull/1568
For more information
If you have any questions or comments about this advisory:
NVD description
py-cord is a an API wrapper for Discord written in Python. Bots creating using py-cord version 2.0.0 are vulnerable to remote shutdown if they are added to the server with the `application.commands` scope without the `bot` scope. Currently, it appears that all public bots that use slash commands are affected. This issue has been patched in version 2.0.1. There are currently no recommended workarounds - please upgrade to a patched version.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free