En bref
- CVE-2022-36094 est une vulnérabilité CRITIQUE (CVSS 9.0) touchant org.xwiki.platform:xwiki-platform-web, xwiki (xwiki).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 64.8%, plus élevée que 99.2% des vulnérabilités.
- Correctif : mettre à jour vers 13.10.6, 14.3-rc-1, 14.3 ou plus récent.
Description
Impact
It's possible to store a JavaScript which will be executed by anyone viewing the history of an attachment containing javascript in its name.
For example, attachment a file with name ><img src=1 onerror=alert(1)>.jpg will execute the alert.
Patches
This issue has been patched in XWiki 13.10.6 and 14.3RC1.
Workarounds
It is possible to replace viewattachrev.vm, the entry point for this attack, by a patched version from the patch without updating XWiki.
References
For more information
If you have any questions or comments about this advisory:
NVD description
XWiki Platform Web Parent POM contains Web resources for the XWiki platform, a generic wiki platform. Starting with version 1.0 and prior to versions 13.10.6 and 14.30-rc-1, it's possible to store JavaScript which will be executed by anyone viewing the history of an attachment containing javascript in its name. This issue has been patched in XWiki 13.10.6 and 14.3RC1. As a workaround, it is possible to replace `viewattachrev.vm`, the entry point for this attack, by a patched version from the patch without updating XWiki.
Autres vulnérabilités de org.xwiki.platform:xwiki-platform-web
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free