En bref
- CVE-2022-37023 est une vulnérabilité MOYENNE (CVSS 6.5) touchant org.apache.geode:geode-core, geode (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.8%, plus élevée que 78.3% des vulnérabilités.
- Correctif : mettre à jour vers 1.15.0 ou plus récent.
Description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
NVD description
Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.
Autres vulnérabilités de org.apache.geode:geode-core
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free