En bref
- CVE-2022-37865 est une vulnérabilité CRITIQUE (CVSS 9.1) touchant org.apache.ivy:ivy, ivy (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 2.1%, plus élevée que 82.1% des vulnérabilités.
- Correctif : mettre à jour vers 2.5.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.ivy:ivy Maven | ≥ 2.4.0, < 2.5.1
| 2.5.1
|
| ivy | ≥ 2.4.0, < 2.5.1
| 2.5.1
|
Description
With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used
pack200 or zip packaging.
For artifacts using the "zip", "jar" or "war" packaging Ivy prior to version 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on
the local fie system that the user executing Ivy has write access to.
Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy version 2.5.1.
NVD description
With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used pack200 or zip packaging. For artifacts using the "zip", "jar" or "war" packaging Ivy prior to 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse "upwards" using ".." sequences can then write files to any location on the local fie system that the user executing Ivy has write access to. Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy 2.5.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free