En bref
- CVE-2022-39280 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant dparse, dependency parser (pyup).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 71.4% des vulnérabilités.
- Correctif : mettre à jour vers 0.5.2, 0.5.1 ou plus récent.
Description
Impact
dparse versions prior to 0.5.1 contain a regular expression that is vulnerable to ReDoS (Regular Expression Denial of Service).
All users parsing index server URLs with dparse are impacted by this vulnerability.
Patches
The Patch is applied in the 0.5.2 version, all users are recommended to upgrade as soon as possible.
Workarounds
Avoid passing index server URLs in the source file to be parsed.
References
https://github.com/pyupio/dparse/tree/security/remove-intensive-regex
For more information
If you have any questions or comments about this advisory:
NVD description
dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free