En bref
- CVE-2022-3971 est une vulnérabilité MOYENNE (CVSS 5.6) touchant matrix irc bridge (matrix), matrix-appservice-irc.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.57%, plus élevée que 47.3% des vulnérabilités.
- Correctif : mettre à jour vers 0.36.0 ou plus récent.
Description
A vulnerability was found in matrix-appservice-irc up to 0.35.1. This vulnerability affects the file src/datastore/postgres/PgDataStore.ts. The manipulation of the argument roomIds leads to sql injection. Upgrading to version 0.36.0 is able to address this issue. The name of the patch is 179313a37f06b298150edba3e2b0e5a73c1415e7. It is recommended to upgrade the affected component.
NVD description
A vulnerability was found in matrix-appservice-irc up to 0.35.1. It has been declared as critical. This vulnerability affects unknown code of the file src/datastore/postgres/PgDataStore.ts. The manipulation of the argument roomIds leads to sql injection. Upgrading to version 0.36.0 is able to address this issue. The name of the patch is 179313a37f06b298150edba3e2b0e5a73c1415e7. It is recommended to upgrade the affected component. VDB-213550 is the identifier assigned to this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free