| Package | Affected versions | Patched versions |
|---|---|---|
| dhis 2 | = 2.39.0≥ 2.35.0, < 2.36.12.1≥ 2.37.0, < 2.37.8.1≥ 2.38.0, < 2.38.2.1 | 2.36.12.12.37.8.12.38.2.1 |
DHIS 2 is an open source information system for data capture, management, validation, analytics and visualization. Through various features of DHIS2, an authenticated user may be able to upload a file which includes embedded javascript. The user could then potentially trick another authenticated user to open the malicious file in a browser which would trigger the javascript code, resulting in a cross-site scripting (XSS) attack. DHIS2 administrators should upgrade to the following hotfix releases: 2.36.12.1, 2.37.8.1, 2.38.2.1, 2.39.0.1. Users unable to upgrade may add the following simple CSP rule in your web proxy to the vulnerable endpoints: `script-src 'none'`. This workaround will prevent all javascript from running on those endpoints.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free