En bref
- CVE-2022-4524 est une vulnérabilité MOYENNE (CVSS 6.1) touchant roots/soil, soil (roots).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.59%, plus élevée que 48.5% des vulnérabilités.
- Correctif : mettre à jour vers 4.1.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| roots/soil Packagist | < 4.1.0
| 4.1.0
|
| soil | < 4.1.0
| 4.1.0
|
Description
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.1.0. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
NVD description
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free