En bref
- CVE-2023-22728 est une vulnérabilité MOYENNE (CVSS 4.3) touchant silverstripe/framework, framework (silverstripe).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.49%, plus élevée que 41.8% des vulnérabilités.
- Correctif : mettre à jour vers 4.12.5 ou plus récent.
Description
The GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access.
Upgrade to silverstripe/framework 4.12.5 or above to address the issue.
Reported by Stephan Bauer from relaxt Webdienstleistungsagentur GmbH
NVD description
Silverstripe Framework is the Model-View-Controller framework that powers the Silverstripe content management system. Prior to version 4.12.15, the GridField print view incorrectly validates the permission of DataObjects potentially allowing a content author to view records they are not authorised to access. Users should upgrade to Silverstripe Framework 4.12.15 or above to address the issue.
Autres vulnérabilités de silverstripe/framework
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free