En bref
- CVE-2023-23934 est une vulnérabilité FAIBLE (CVSS 3.5) touchant werkzeug, werkzeug (palletsprojects).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.51%, plus élevée que 43.3% des vulnérabilités.
- Correctif : mettre à jour vers 2.2.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| werkzeug PyPI | < 2.2.3
| 2.2.3
|
| werkzeug | < 2.2.3
| 2.2.3
|
Description
Browsers may allow "nameless" cookies that look like =value instead of key=value. A vulnerable browser may allow a compromised application on an adjacent subdomain to exploit this to set a cookie like =__Host-test=bad for another subdomain.
Werkzeug <= 2.2.2 will parse the cookie =__Host-test=bad as __Host-test=bad. If a Werkzeug application is running next to a vulnerable or malicious subdomain which sets such a cookie using a vulnerable browser, the Werkzeug application will see the bad cookie value but the valid cookie key.
NVD description
Werkzeug is a comprehensive WSGI web application library. Browsers may allow "nameless" cookies that look like `=value` instead of `key=value`. A vulnerable browser may allow a compromised application on an adjacent subdomain to exploit this to set a cookie like `=__Host-test=bad` for another subdomain. Werkzeug prior to 2.2.3 will parse the cookie `=__Host-test=bad` as __Host-test=bad`. If a Werkzeug application is running next to a vulnerable or malicious subdomain which sets such a cookie using a vulnerable browser, the Werkzeug application will see the bad cookie value but the valid cookie key. The issue is fixed in Werkzeug 2.2.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free