En bref
- CVE-2023-28119 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant github.com/crewjam/saml, saml (saml project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.96%, plus élevée que 61.5% des vulnérabilités.
- Correctif : mettre à jour vers 0.4.13 ou plus récent.
Description
Our use of flate.NewReader does not limit the size of the input. The user could pass more than 1 MB of data in the HTTP request to the processing functions, which will be decompressed server-side using the Deflate algorithm. Therefore, after repeating the same request multiple times, it is possible to achieve a reliable crash since the operating system kills the process.
NVD description
The crewjam/saml go library contains a partial implementation of the SAML standard in golang. Prior to version 0.4.13, the package's use of `flate.NewReader` does not limit the size of the input. The user can pass more than 1 MB of data in the HTTP request to the processing functions, which will be decompressed server-side using the Deflate algorithm. Therefore, after repeating the same request multiple times, it is possible to achieve a reliable crash since the operating system kills the process. This issue is patched in version 0.4.13.
Autres vulnérabilités de github.com/crewjam/saml
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free