| Package | Affected versions | Patched versions |
|---|---|---|
| mongoose | = 7.10 |
Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free