En bref
- CVE-2023-30614 est une vulnérabilité MOYENNE (CVSS 6.1) touchant pay, pay (pay project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.45%, plus élevée que 39.4% des vulnérabilités.
- Correctif : mettre à jour vers 6.3.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pay RubyGems | < 6.3.2
| 6.3.2
|
| pay | < 6.3.2
| 6.3.2
|
Description
Impact
A payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality.
Patches
This has been patched in version 6.3.2 and above.
Pay will now sanitize the back parameter and only permit relative paths.
NVD description
Pay is a payments engine for Ruby on Rails 6.0 and higher. In versions prior to 6.3.2 a payments info page of Pay is susceptible to reflected Cross-site scripting. An attacker could create a working URL that renders a javascript link to a user on a Rails application that integrates Pay. This URL could be distributed via email to specifically target certain individuals. If the targeted application contains a functionality to submit user-generated content (such as comments) the attacker could even distribute the URL using that functionality. This has been patched in version 6.3.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free