En bref
- CVE-2023-32314 est une vulnérabilité CRITIQUE (CVSS 10.0) touchant vm2 (vm2 project), vm2.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 8.1%, plus élevée que 94.8% des vulnérabilités.
- Correctif : mettre à jour vers 3.9.18 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| vm2 | < 3.9.18
| 3.9.18
|
| vm2 npm | < 3.9.18
| 3.9.18
|
Description
A sandbox escape vulnerability exists in vm2 for versions up to 3.9.17. It abuses an unexpected creation of a host object based on the specification of Proxy.
Impact
A threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox.
Patches
This vulnerability was patched in the release of version 3.9.18 of vm2.
Workarounds
None.
References
PoC - https://gist.github.com/arkark/e9f5cf5782dec8321095be3e52acf5ac
For more information
If you have any questions or comments about this advisory:
Thanks to @arkark (Takeshi Kaneko) of GMO Cybersecurity by Ierae, Inc. for disclosing this vulnerability.
NVD description
vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free