En bref
- CVE-2023-34110 est une vulnérabilité FAIBLE (CVSS 2.7) touchant flask-appbuilder, flask-appbuilder (flask-appbuilder project).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.68%, plus élevée que 52.3% des vulnérabilités.
- Correctif : mettre à jour vers 4.3.2 ou plus récent.
Description
Impact
An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password.
Patches
Fixed on 4.3.2
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free