En bref
- CVE-2023-38504 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant sails (sailsjs), sails.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.94%, plus élevée que 61.0% des vulnérabilités.
- Correctif : mettre à jour vers 1.5.7 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| sails | < 1.5.7
| 1.5.7
|
| sails npm | < 1.5.7
| 1.5.7
|
Description
Impact
In Sails apps <=v1.5.6, an attacker can send a virtual request that will cause the node process to crash.
Patches
This behavior was fixed in Sails v1.5.7
Workarounds
Disable the sockets hook and remove the sails.io.js client
References
https://github.com/balderdashy/sails/pull/7287
Big thanks to @ThomasRinsma at Codean!
NVD description
Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free