En bref
- CVE-2023-40311 est une vulnérabilité MOYENNE (CVSS 4.8) touchant org.opennms:opennms-webapp, horizon (opennms), meridian (opennms).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.74%, plus élevée que 54.7% des vulnérabilités.
- Correctif : mettre à jour vers 32.0.2, 2022.1.19, 2023.1.6, 2020.1.38 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.opennms:opennms-webapp Maven | ≥ 31.0.8, < 32.0.2
| 32.0.2
|
| horizon | ≥ 31.0.8, < 32.0.2
| 32.0.2
|
| meridian | ≥ 2022.1.0, < 2022.1.19≥ 2023.1.0, < 2023.1.6< 2020.1.38
| 2022.1.192023.1.62020.1.38
|
Description
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
NVD description
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
Autres vulnérabilités de org.opennms:opennms-webapp
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free