En bref
- CVE-2023-40579 est une vulnérabilité MOYENNE (CVSS 6.5) touchant github.com/openfga/openfga, openfga (openfga).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.55%, plus élevée que 45.7% des vulnérabilités.
- Correctif : mettre à jour vers 1.3.1 ou plus récent.
Description
Overview
Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. This means that the API sometimes returns more objects than it should.
Am I Affected?
The vulnerability affects customers using ListObjects with specific models. The affected models contain expressions of type rel1 from type1.
Fix
Update to v1.3.1.
Backward Compatibility
This update is backward compatible.
NVD description
OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. Some end users of OpenFGA v1.3.0 or earlier are vulnerable to authorization bypass when calling the ListObjects API. The vulnerability affects customers using `ListObjects` with specific models. The affected models contain expressions of type `rel1 from type1`. This issue has been patched in version 1.3.1.
Autres vulnérabilités de github.com/openfga/openfga
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free