En bref
- CVE-2023-46131 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.grails:grails-databinding, grails (grails).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.72%, plus élevée que 54.1% des vulnérabilités.
- Correctif : mettre à jour vers 3.3.17, 4.1.3, 5.3.4, 6.1.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.grails:grails-databinding Maven | ≥ 2.0.0, < 3.3.17≥ 4.0.0, < 4.1.3≥ 5.0.0, < 5.3.4≥ 6.0.0, < 6.1.0
| 3.3.174.1.35.3.46.1.0
|
| grails | ≥ 4.0.0, < 4.1.3≥ 5.0.0, < 5.3.4≥ 6.0.0, < 6.1.0< 3.3.17
| 4.1.35.3.46.1.03.3.17
|
Description
Impact
A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable.
Patches
Patches are available for Grails 3 and later.
Workarounds
No workaround is possible except to avoid data binding to request data.
References
NVD description
Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.
Autres vulnérabilités de org.grails:grails-databinding
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free