En bref
- CVE-2023-46240 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant codeigniter4/framework, codeigniter (codeigniter).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.78%, plus élevée que 55.8% des vulnérabilités.
- Correctif : mettre à jour vers 4.4.3 ou plus récent.
Description
Impact
If an error or exception occurs in CodeIgniter4 v4.4.2 and earlier, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked.
Patches
Upgrade to v4.4.3 or later. See upgrading guide.
Workarounds
Replace ini_set('display_errors', '0') with ini_set('display_errors', 'Off') in app/Config/Boot/production.php.
For more information
If you have any questions or comments about this advisory:
NVD description
CodeIgniter is a PHP full-stack web framework. Prior to CodeIgniter4 version 4.4.3, if an error or exception occurs, a detailed error report is displayed even if in the production environment. As a result, confidential information may be leaked. Version 4.4.3 contains a patch. As a workaround, replace `ini_set('display_errors', '0')` with `ini_set('display_errors', 'Off')` in `app/Config/Boot/production.php`.
Autres vulnérabilités de codeigniter4/framework
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free