En bref
- CVE-2023-46250 est une vulnérabilité MOYENNE (CVSS 5.5) touchant pypdf, pypdf (py-pdf).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.25%, plus élevée que 17.0% des vulnérabilités.
- Correctif : mettre à jour vers 3.17.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | ≥ 3.7.0, < 3.17.0
| 3.17.0
|
| pypdf | ≥ 3.7.0, < 3.17.0
| 3.17.0
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop.
This infinite loop blocks the current process and can utilize a single core of the CPU by 100%. It does not affect memory usage.
That is, for example, the case when the pypdf-user manipulates an incoming malicious PDF e.g. by merging it with another PDF or by adding annotations.
Patches
The issue was fixed with #2264
Workarounds
If you cannot update your version of pypdf, you should modify pypdf/generic/_data_structures.py just like #2264 did.
NVD description
pypdf is a free and open-source pure-python PDF library. An attacker who uses a vulnerability present in versions 3.7.0 through 3.16.4 can craft a PDF which leads to an infinite loop. This infinite loop blocks the current process and can utilize a single core of the CPU by 100%. It does not affect memory usage. That is, for example, the case when the pypdf-user manipulates an incoming malicious PDF e.g. by merging it with another PDF or by adding annotations. The issue was fixed in version 3.17.0. As a workaround, apply the patch manually by modifying `pypdf/generic/_data_structures.py`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free