En bref
- CVE-2023-49277 est une vulnérabilité MOYENNE (CVSS 6.1) touchant dpaste, dpaste (darrennathanael).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.52%, plus élevée que 44.2% des vulnérabilités.
- Correctif : mettre à jour vers 3.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| dpaste PyPI | < 3.8
| 3.8
|
| dpaste | < 3.8
| 3.8
|
Description
Impact
A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities.
Patches
- A patch has been applied to the dpaste GitHub repository to address the specific content value injection vulnerability.
- Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability.
- The patch can be viewed and applied from the following link: dpaste Commit Patch
Workarounds
At this time, the recommended course of action is to apply the provided patch to the affected systems. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.
NVD description
dpaste is an open source pastebin application written in Python using the Django framework. A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities. Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free