En bref
- CVE-2023-50292 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant org.apache.solr:solr-core, solr (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 3.0%, plus élevée que 87.5% des vulnérabilités.
- Correctif : mettre à jour vers 8.11.3, 9.3.0, 9.4.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| org.apache.solr:solr-core Maven | ≥ 8.10.0, < 8.11.3≥ 9.0.0, < 9.3.0
| 8.11.39.3.0
|
| solr | ≥ 6.0.0, < 8.11.3≥ 9.0.0, < 9.4.1
| 8.11.39.4.1
|
Description
Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr.
This issue affects Apache Solr from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0.
The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets.
However, when the feature was created, the "trust" (authentication) of these configSets was not considered.
External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution.
Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer.
Users are recommended to upgrade to version 9.3.0 or 8.11.3, both of which fix the issue.
NVD description
Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr.
This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0.
The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets.
However, when the feature was created, the "trust" (authentication) of these configSets was not considered.
External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution.
Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer.
Users are recommended to upgrade to version 9.3.0, which fixes the issue.
Autres vulnérabilités de org.apache.solr:solr-core
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free