En bref
- CVE-2023-50725 est une vulnérabilité MOYENNE (CVSS 6.1) touchant resque, resque (resque).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.53%, plus élevée que 44.7% des vulnérabilités.
- Correctif : mettre à jour vers 2.2.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| resque RubyGems | < 2.2.1
| 2.2.1
|
| resque | < 2.2.1
| 2.2.1
|
Description
Impact
The following paths in resque-web have been found to be vulnerable to reflected XSS:
/failed/?class=<script>alert(document.cookie)</script>
/queues/><img src=a onerror=alert(document.cookie)>
Patches
v2.2.1
Workarounds
No known workarounds at this time. It is recommended to not click on 3rd party or untrusted links to the resque-web interface until you have patched your application.
References
https://github.com/resque/resque/pull/1790
NVD description
Resque is a Redis-backed Ruby library for creating background jobs, placing them on multiple queues, and processing them later. The following paths in resque-web have been found to be vulnerable to reflected XSS: "/failed/?class=<script>alert(document.cookie)</script>" and "/queues/><img src=a onerror=alert(document.cookie)>". This issue has been patched in version 2.2.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free