En bref
- CVE-2023-50943 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant apache-airflow, airflow (apache).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.2%, plus élevée que 68.7% des vulnérabilités.
- Correctif : mettre à jour vers 2.8.1, 2.8.1rc1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | < 2.8.1< 2.8.1rc1
| 2.8.12.8.1rc1
|
| airflow | < 2.8.1
| 2.8.1
|
Description
Apache Airflow, versions before 2.8.1, have a vulnerability that allows a potential attacker to poison the XCom data by bypassing the protection of "enable_xcom_pickling=False" configuration setting resulting in poisoned data after XCom deserialization. This vulnerability is considered low since it requires a DAG author to exploit it. Users are recommended to upgrade to version 2.8.1 or later, which fixes this issue.
NVD description
Apache Airflow, versions before 2.8.1, have a vulnerability that allows a potential attacker to poison the XCom data by bypassing the protection of "enable_xcom_pickling=False" configuration setting resulting in poisoned data after XCom deserialization. This vulnerability is considered low since it requires a DAG author to exploit it. Users are recommended to upgrade to version 2.8.1 or later, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free