En bref
- CVE-2023-51699 est une vulnérabilité MOYENNE (CVSS 6.0) touchant github.com/fluid-cloudnative/fluid, fluid (linuxfoundation).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.61%, plus élevée que 49.3% des vulnérabilités.
- Correctif : mettre à jour vers 0.9.3 ou plus récent.
Description
Impact
OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data.
Patches
For users who're using version < 0.9.3 with JuicefsRuntime, upgrade to v0.9.3.
References
Are there any links users can visit to find out more?
Credits
Special thanks to the discovers of this issue:
Xiaozheng Zhang [email protected]
NVD description
Fluid is an open source Kubernetes-native Distributed Dataset Orchestrator and Accelerator for data-intensive applications. An OS command injection vulnerability within the Fluid project's JuicefsRuntime can potentially allow an authenticated user, who has the authority to create or update the K8s CRD Dataset/JuicefsRuntime, to execute arbitrary OS commands within the juicefs related containers. This could lead to unauthorized access, modification or deletion of data. Users who're using versions < 0.9.3 with JuicefsRuntime should upgrade to v0.9.3.
Autres vulnérabilités de github.com/fluid-cloudnative/fluid
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free