En bref
- CVE-2024-10975 est une vulnérabilité ÉLEVÉE (CVSS 7.7) touchant github.com/hashicorp/nomad, nomad (hashicorp).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.45%, plus élevée que 39.1% des vulnérabilités.
- Correctif : mettre à jour vers 1.9.2, 1.7.15, 1.8.7 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/nomad Go | ≤ 1.9.1< 1.9.2
| 1.9.2
|
| nomad | ≥ 1.3.0, < 1.7.15≥ 1.3.0, < 1.9.2≥ 1.8.0, < 1.8.7≥ 1.9.0, < 1.9.2
| 1.7.151.9.21.8.7
|
Description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
NVD description
Nomad Community and Nomad Enterprise ("Nomad") volume specification is vulnerable to arbitrary cross-namespace volume creation through unauthorized Container Storage Interface (CSI) volume writes. This vulnerability, identified as CVE-2024-10975, is fixed in Nomad Community Edition 1.9.2 and Nomad Enterprise 1.9.2, 1.8.7, and 1.7.15.
Autres vulnérabilités de github.com/hashicorp/nomad
Tout voir →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free