En bref
- CVE-2024-2035 est une vulnérabilité MOYENNE (CVSS 6.5) touchant zenml, zenml (zenml).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.63%, plus élevée que 50.1% des vulnérabilités.
- Correctif : mettre à jour vers 0.56.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| zenml PyPI | < 0.56.2
| 0.56.2
|
| zenml | < 0.56.2
| 0.56.2
|
Description
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the active status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
NVD description
An improper authorization vulnerability exists in the zenml-io/zenml repository, specifically within the API PUT /api/v1/users/id endpoint. This vulnerability allows any authenticated user to modify the information of other users, including changing the `active` status of user accounts to false, effectively deactivating them. This issue affects version 0.55.3 and was fixed in version 0.56.2. The impact of this vulnerability is significant as it allows for the deactivation of admin accounts, potentially disrupting the functionality and security of the application.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free