En bref
- CVE-2024-21649 est une vulnérabilité ÉLEVÉE (CVSS 8.8) touchant vantage6, vantage6 (vantage6).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 1.3%, plus élevée que 69.7% des vulnérabilités.
- Correctif : mettre à jour vers 4.2.0 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| vantage6 PyPI | < 4.2.0
| 4.2.0
|
| vantage6 | < 4.2.0
| 4.2.0
|
Description
Impact
Authenticated users could inject code into algorithm environment variables
Workarounds
No
NVD description
The vantage6 technology enables to manage and deploy privacy enhancing technologies like Federated Learning (FL) and Multi-Party Computation (MPC). Prior to 4.2.0, authenticated users could inject code into algorithm environment variables, resulting in remote code execution. This vulnerability is patched in 4.2.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free