En bref
- CVE-2024-2171 est une vulnérabilité MOYENNE (CVSS 4.8) touchant zenml, zenml (zenml).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.37%, plus élevée que 30.5% des vulnérabilités.
- Correctif : mettre à jour vers 0.56.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| zenml PyPI | < 0.56.2
| 0.56.2
|
| zenml | < 0.56.2
| 0.56.2
|
Description
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
NVD description
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free